Technical Requirements

Minimum System Requirements (last updated on 04/12/22)

Windows

  • Windows 7, Windows 8, Windows 8.1, Windows 10 or later
  • An Intel Pentium 4 processor or later that's SSE2 capable

Mac

  • OS X Yosemite 10.10 or later

Linux

  • 64-bit Ubuntu 14.04+, Debian 8+, openSUSE 13.3+, or Fedora Linux 24+
  • An Intel Pentium 4 processor or later that's SSE2 capable 

Android

  • Android OS version 4.1.1 and above that are compatible with Google Play.

iPad, iPhone, and iPod Touch

  • iOS 10 or later

Preferred Browsers

  • Chrome, Firefox, Safari, and Microsoft Edge. However, any modern browser should work.